summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzer0-x2023-03-07 07:14:19 +0300
committerzer0-x2023-03-07 07:14:19 +0300
commit8cbfd8bf589c0e3d1ca67cfe9250f950a63d6375 (patch)
treee6702935a94faaf2c546db3fe500d34d814c1d5a /PKGBUILD
downloadaur-8cbfd8bf589c0e3d1ca67cfe9250f950a63d6375.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6477756ee3d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: zer0-x < Matrix: "@zer0-x:kde.org" >
+
+pkgname="fish-tide-git"
+_pkgname=${pkgname%-git}
+pkgver=5.r8.g6495113
+pkgrel=1
+pkgdesc="Flexible and asynchronous Fish prompt"
+arch=("any")
+url="https://github.com/IlanCosman/tide"
+license=("MIT")
+depends=("fish")
+makedepends=("git")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+install="${pkgname}.install"
+source=("${pkgname}::git+${url}#branch=main")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${pkgname}"
+
+ find conf.d functions -type f -exec install -Dm 755 '{}' "${pkgdir}/etc/fish/{}" \;
+
+ install -Dm644 completions/* -t "${pkgdir}/usr/share/fish/vendor_completions.d/"
+
+ install -Dm755 "LICENSE.md" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE-MIT"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+}