summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:39:05 +0200
committerL.G. Sarmiento2015-06-14 19:39:05 +0200
commitdf3f93ef54f33e71fc1298d774094297e4f75bd1 (patch)
treea72ba93fce8b968520077bfcfe2e81c312d0b7a6 /PKGBUILD
downloadaur-df3f93ef54f33e71fc1298d774094297e4f75bd1.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91d6ba18c778
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Submitter: L.G. Sarmiento <lgsarmientop-ala-unal.edu.co>
+pkgname=fityk-git
+pkgver=20140531
+pkgrel=1
+pkgdesc="A program for nonlinear fitting of analytical functions to data."
+url="http://fityk.nieto.pl/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('lua' 'wxgtk' 'xylib' 'ruby' 'python')
+makedepends=('boost' 'desktop-file-utils' 'git' 'python2-sphinx' 'swig')
+optdepends=('gnuplot: can be used with the CLI')
+provides=("fityk")
+options=('!libtool')
+install="fityk.install"
+md5sums=()
+
+_gitroot="http://github.com/wojdyr/fityk.git"
+
+build() {
+ [ -d ${srcdir}/${pkgname} ] || mkdir ${srcdir}/${pkgname}
+ #thanks to masutu and in general the team from the fityk AUR package
+ #This nowadays is almost identical to that one.
+ cd ${srcdir}/${pkgname}
+ git clone --depth 1 $_gitroot .
+
+ #it doesn't build with sphinx for python3
+ sed -i 's#sphinx-build#sphinx-build2#' doc/Makefile
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --with-wx-config=/usr/bin/wx-config
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ make DESTDIR=${pkgdir} install
+}