summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2015-09-24 10:09:45 -0400
committergraysky2015-09-24 10:09:45 -0400
commitede1d2133a2c62ebccd3891458e705aa55e43db5 (patch)
treed44c102ba5e6e814cfbbaf84defd4648e48eee42 /PKGBUILD
parent7de38cd106dcf5ea3f3ef07ea9a18949811958b2 (diff)
downloadaur-ede1d2133a2c62ebccd3891458e705aa55e43db5.tar.gz
Update to 3.71-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 673e715d3897..c03a3a264f76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=flac2all
pkgver=3.71
-pkgrel=3
+pkgrel=4
pkgdesc="Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata."
arch=('any')
-url="http://code.google.com/p/flac2all"
+url="https://github.com/ZivaVatra/flac2all"
license=('GPL2')
conflicts=('flac2all-svn')
depends=('flac' 'python2')
@@ -13,14 +13,13 @@ optdepends=('lame: for mp3 support'
'vorbis-tools: for ogg support'
'opus-tools: for opus support')
-# temp hosting until Ziva finds a permanent host
-#source=(http://$pkgname.googlecode.com/files/"$pkgname"_v$pkgver.py
-source=("flac2all_v$pkgver.py::http://flac2all.witheredfire.com/cgi-bin/download.cgi?download=flac2all_v$pkgver.py"
-$pkgname.1)
-sha256sums=('7b451635f2c680431b227fc07e356f58c2a709d88e2bfe9ff021b675d6b54f26'
- 'a55806a227d5370681dc42d6f86fc7a3f3e7ae7e460bbc1a5f3065721b3f75bb')
+# graysky is temp hosting on his github until Ziva tags his releases
+source=("https://github.com/graysky2/flac2all/archive/v$pkgver.tar.gz")
+sha256sums=('2bae1c535dad613f659ea42e8c769f4bb9a89b940edfbeaee60e8561ffcf77e8')
package() {
- install -Dm755 flac2all_v$pkgver.py "$pkgdir"/usr/bin/$pkgname
- install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 stable/$pkgname.py "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 stable/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
}