summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Squartini2015-07-21 09:30:26 +0900
committerNicola Squartini2015-07-21 09:30:26 +0900
commit8e74132bdb4016a28a91a11233a5bb3acbbe52a7 (patch)
tree51da7c0241f8d64873cf0beed2d641c883d5310a /PKGBUILD
downloadaur-8e74132bdb4016a28a91a11233a5bb3acbbe52a7.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2dfe0e3814a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Nicola Squartini <tensor5@gmail.com>
+_hkgname=flaccuraterip
+pkgname=flaccuraterip
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="Verify FLAC files ripped from CD using AccurateRip™"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('GPL3')
+arch=('i686' 'x86_64')
+makedepends=('ghc' 'haskell-binary>=0.5' 'haskell-binary<0.8' 'haskell-deepseq>=1.3' 'haskell-deepseq<1.5' 'haskell-http>=4000.2' 'haskell-http<4000.3' 'haskell-optparse-applicative>=0.10' 'haskell-optparse-applicative<0.12' 'haskell-process>=1.2' 'haskell-process<1.3')
+depends=('gmp')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+sha256sums=('108d589f27754da0f2716787c99bdcec03e6cf85326e2030805844d48275a46f')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
+ runhaskell Setup build
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+}