summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit80b15e9a8b181091db224c504f8e2f40dd5fcada (patch)
treef83b7f352e4eeb1e52124675efd169b7027dc4b3 /PKGBUILD
downloadaur-flam3.tar.gz
Move from [community] to AUR in connection with the spring cleaning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a451edabd893
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer:
+# Contributor: Eric Bélanger <eric@archlinux.org>
+
+pkgname=flam3
+pkgver=3.1.1
+pkgrel=2
+pkgdesc="Tools to create/display fractal flames: algorithmically generated images and animations"
+arch=('x86_64')
+url="http://flam3.com/"
+license=('GPL3')
+depends=('libjpeg' 'libpng' 'libxml2')
+source=(https://github.com/scottdraves/flam3/archive/v${pkgver}.tar.gz)
+sha1sums=('0bab806472b82f8fd20a8f96023ab80151c2f5ba')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --enable-shared
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}