summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarol Babioch2019-02-08 10:43:38 +0100
committerKarol Babioch2019-02-08 10:43:38 +0100
commitaa3b287df48c4bee04e1ef6c735b079d64feb1b4 (patch)
treebda30a1ce1cf9c0a0fb88621d67441447e26df20 /PKGBUILD
parent193c6573d3eeb7c9929e1927d1e906bb3fa809e8 (diff)
downloadaur-flamethrower-git.tar.gz
Set pkgver automatically based on Git tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 866788ebff46..335d5df4219c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=flamethrower-git
_pkgname=${pkgname%-git}
-pkgver=0
+pkgver=0.9.r5.20dabbc
pkgrel=1
pkgdesc="DNS performance and functional testing utility"
arch=('i686' 'x86_64')
@@ -13,6 +13,11 @@ makedepends=('cmake')
source=("git+https://github.com/DNS-OARC/flamethrower.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
build() {
cd "${srcdir}/${_pkgname}"
# Fix a issue with CMake package name of ldns