summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarol Babioch2019-02-03 13:52:22 +0100
committerKarol Babioch2019-02-03 13:52:22 +0100
commit193c6573d3eeb7c9929e1927d1e906bb3fa809e8 (patch)
treeee326d0e75529e08f376981a3270b2d4d557d6fa /PKGBUILD
downloadaur-193c6573d3eeb7c9929e1927d1e906bb3fa809e8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..866788ebff46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Karol Babioch <karol@babioch.de>
+
+pkgname=flamethrower-git
+_pkgname=${pkgname%-git}
+pkgver=0
+pkgrel=1
+pkgdesc="DNS performance and functional testing utility"
+arch=('i686' 'x86_64')
+url="https://github.com/DNS-OARC/flamethrower"
+license=('APACHE')
+depends=('ldns' 'libuv')
+makedepends=('cmake')
+source=("git+https://github.com/DNS-OARC/flamethrower.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ # Fix a issue with CMake package name of ldns
+ sed -i 's/libldns/ldns/' CMakeLists.txt
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd build
+ install -Dm0755 flame "$pkgdir/usr/bin/flame"
+}