summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzrhoffman2019-06-17 01:10:53 -0500
committerzrhoffman2019-06-17 01:10:53 -0500
commita7ef562d789b85db4f40c8f7667a31b0c40454d6 (patch)
tree3aa74045649c929d8ee73a9dcdfc8c5dea83f52c /PKGBUILD
downloadaur-a7ef562d789b85db4f40c8f7667a31b0c40454d6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83f48f9e9d3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Zach Hoffman <zach@zrhoffman.net>
+
+pkgname=(flashplugin-debug pepper-flash-debug)
+pkgver=32.0.0.207
+pkgrel=1
+pkgdesc="Adobe Flash Player debugger"
+arch=('x86_64')
+url="https://www.adobe.com/support/flashplayer/debug_downloads.html"
+license=('custom' 'LGPL')
+options=('!strip')
+source=(flash_player_npapi_linux_debug_$pkgver.x86_64.tar.gz::https://fpdownload.macromedia.com/pub/flashplayer/updaters/32/flash_player_npapi_linux_debug.x86_64.tar.gz
+ flash_player_ppapi_linux_debug_$pkgver.x86_64.tar.gz::https://fpdownload.macromedia.com/pub/flashplayer/updaters/32/flash_player_ppapi_linux_debug.x86_64.tar.gz)
+noextract=(${source[@]%::*})
+sha256sums=('fb705577e53d312dbac63d58a88f8dbdf56a9df2a7d42b96c749e4ab14a6ad6c'
+ 'd00c5400af536836a138ec084a65e4374cd8c3f9d33d5b0a2871fe95ac0615f4')
+
+prepare() {
+ local _dir
+ for f in *.tar.gz; do
+ _dir=$(grep -Eo '([np]papi)' <<< $f)
+ mkdir -p $_dir
+ tar xfC $f $_dir
+ done
+}
+
+package_flashplugin-debug() {
+ pkgdesc+=" NPAPI"
+ depends=('libxt' 'gtk2' 'nss' 'curl' 'hicolor-icon-theme')
+ optdepends=('libvdpau: GPU acceleration on Nvidia cards')
+ provides=("flashplugin=${pkgver}")
+ conflicts=('flashplugin')
+
+ cd npapi
+ install -Dm644 libflashplayer.so "$pkgdir/usr/lib/mozilla/plugins/libflashplayer.so"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" license.pdf LGPL/notice.txt
+
+ install -D -t "$pkgdir/usr/bin" usr/bin/flash-player-properties
+ cp -a usr/share/{applications,icons} "$pkgdir/usr/share/"
+
+}
+
+package_pepper-flash-debug() {
+ pkgdesc+=" PPAPI"
+ depends=('gcc-libs')
+ optdepends=('flashplugin-debug: settings utility')
+ provides=("pepper-flash=${pkgver}")
+ conflicts=('pepper-flash')
+
+ cd ppapi
+ install -Dm644 -t "$pkgdir/usr/lib/PepperFlash" manifest.json libpepflashplayer.so
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" license.pdf LGPL/notice.txt
+}
+
+# vim:set ts=2 sw=2 et: