summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNico Huber2024-02-12 23:39:45 +0100
committerNico Huber2024-02-12 23:39:45 +0100
commitee0ed2a4166c76c9d3d7e907aaa964ef84b68562 (patch)
tree92198d0b2fd911d698e81030780f3c6d97518963 /PKGBUILD
parenta1f42a78c64ecbd6cc947315f825a82f088378da (diff)
downloadaur-ee0ed2a4166c76c9d3d7e907aaa964ef84b68562.tar.gz
Bump to v1.0.1
Fixed compatibility with libgpiod >= 2.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 001abd933979..b57ef8c7dddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname="flashprog"
pkgdesc="Flashprog is a utility which can be used to detect, read, erase, or write BIOS chips (DIP, PLCC, SPI)."
-pkgver=1.0
+pkgver=1.0.1
pkgrel=1
url="https://flashprog.org/"
license=('GPL')
source=(git+https://review.sourcearcade.org/flashprog.git?signed#tag=v${pkgver})
validpgpkeys=('2853079C9C66AB7E82C64966A5C163B7E557CAEB')
sha256sums=('SKIP')
-depends=('pciutils' 'libusb' 'libftdi' 'libjaylink') # libgpiod became incompatible with 2.0
+depends=('pciutils' 'libusb' 'libftdi' 'libjaylink' 'libgpiod')
makedepends=('git' 'make')
optdepends=("dmidecode: for SMBIOS/DMI table decoder support")
arch=('riscv64' 'aarch64' 'armv6h' 'armv7h' 'i686' 'x86_64')
build() {
cd "${srcdir}/${pkgname}"
- make CONFIG_LINUX_GPIO_SPI=no
+ make
}
package() {