summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2018-04-05 15:32:12 -0400
committerGuillaume Horel2018-04-05 15:32:12 -0400
commit06e18f2146e6a42dc1d77c274f5df659e0a2e0a9 (patch)
tree514efa5fe5e064087f2f714bc4efed54b75e0fe6 /PKGBUILD
downloadaur-06e18f2146e6a42dc1d77c274f5df659e0a2e0a9.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..123f8a39408b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
+
+pkgname=flatbuffers-static
+_pkgname=flatbuffers
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='An efficient cross platform serialization library for C++, with support for Java, C# and Go'
+arch=(x86_64)
+url='http://google.github.io/flatbuffers/'
+license=(Apache)
+depends=(gcc-libs)
+makedepends=(cmake)
+options=('staticlibs')
+source=($pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('c45029c0a0f1a88d416af143e34de96b3091642722aa2d8c090916c6d1498c2e')
+provides=('flatbuffers')
+confligs=('flatbuffers')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$_pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd build
+ make test
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+ install -Dm755 flatc -t "$pkgdir"/usr/bin
+}