summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleix Pol2016-05-25 01:18:29 +0200
committerAleix Pol2016-05-25 01:18:29 +0200
commiteaa19cfdc7a4fd1369f07a382e8ac3fb5895a7d5 (patch)
tree813e3407f71f92fbd8b8f8821413ef8d80412764 /PKGBUILD
parent76ebcb6777334c4340d336077f2f2fa98fca3a14 (diff)
downloadaur-eaa19cfdc7a4fd1369f07a382e8ac3fb5895a7d5.tar.gz
update package as suggested by palasso
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 54 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 449fae269002..5fac31435e52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,61 @@
pkgname=flatpak-git
-pkgver=1
+pkgver=0.6.2.r1.gcb41e1b
pkgrel=1
-pkgdesc='An application deployment framework for desktop apps'
-url='http://www.freedesktop.org/software/flatpak'
-license=('GPL2')
-arch=('i686' 'x86_64')
-makedepends=('git' 'docbook-xsl')
-depends=('ostree' 'libseccomp' 'fuse' 'libxau' 'json-glib' 'libelf')
-_gitroot=("https://github.com/alexlarsson/xdg-app.git")
-_gitname="xdg-app"
+pkgdesc="Application deployment framework for desktop apps"
+url="http://flatpak.org"
+arch=(i686 x86_64)
+license=(GPL)
+depends=(dbus systemd glib2 libsoup polkit xorg-xauth libgsystem ostree fuse
+ json-glib libseccomp libarchive libelf libcap)
+makedepends=(intltool python libxslt gobject-introspection gtk-doc git)
+source=("flatpak-git::git+https://github.com/flatpak/flatpak"
+ "git+https://git.gnome.org/browse/libglnx"
+ "git+https://github.com/projectatomic/bubblewrap")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+provides=(flatpak)
+conflicts=(flatpak)
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+
+ git submodule init
+ git config --local submodule.libglnx.url "$srcdir/libglnx"
+ git config --local submodule.bubblewrap.url "$srcdir/bubblewrap"
+ git submodule update
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --sbindir=/usr/bin --libexecdir=/usr/lib --disable-static \
+ --enable-gtk-doc --with-priv-mode=setuid
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-package() {
- cd "$startdir/src"
-
- if [ -d "$startdir/src/$_gitname" ] ; then
- cd $_gitname && git pull origin
- else
- git clone "$_gitroot"
- cd $_gitname
- fi
-
- cd "$srcdir/$_gitname"
- ./autogen.sh
- ./configure --prefix=/usr --libexecdir=/usr/lib --sysconfdir=/etc --disable-userns
make
+}
- cd "$srcdir/$_gitname"
- make DESTDIR="$pkgdir" install
+check() {
+ cd $pkgname
+ make -k check
}
+package() {
+ cd $pkgname
+
+ make DESTDIR="$pkgdir" install
+
+ # Fixup mode to match polkit
+ install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"
+}