summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin Bayer2020-06-22 20:37:31 +0200
committerDevin Bayer2020-06-22 20:37:31 +0200
commite29f78682b7b33b026b0d68bb6e52245d3a5c2d3 (patch)
treea54520291f64d1f0b876c32b07b0801e25bb97b1 /PKGBUILD
downloadaur-e29f78682b7b33b026b0d68bb6e52245d3a5c2d3.tar.gz
new package: flatpak-xdg-utils-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8883d09db494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Devin Bayer <dev@doubly.so>
+pkgname=flatpak-xdg-utils-git
+pkgver=1.0.1.r7.g4fdd2e2
+pkgrel=1
+pkgdesc="Utilities for containerized apps to launch programs outside the container"
+arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/flatpak/flatpak-xdg-utils"
+license=('GPL')
+depends=()
+makedepends=()
+source=('git+https://github.com/flatpak/flatpak-xdg-utils.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/flatpak-xdg-utils"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ meson --prefix /usr \
+ --buildtype=plain \
+ --bindir=/usr/libexec/flatpak-xdg-utils \
+ -Dinstalled_tests=true \
+ "$srcdir/flatpak-xdg-utils" build
+
+ ninja -Cbuild
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -Cbuild install
+ mkdir -p $pkgdir/usr/bin
+ ln -s /usr/libexec/flatpak-xdg-utils/flatpak-spawn $pkgdir/usr/bin/
+}