summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-02-22 01:53:15 +0800
committerzxp198210052023-02-22 01:53:15 +0800
commit653806fae3200fd6664335cb615505dddebe9f88 (patch)
tree21d6a075263b237b20e43edf328bd86feced0ca8 /PKGBUILD
downloadaur-653806fae3200fd6664335cb615505dddebe9f88.tar.gz
the first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c2e145454b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=flawesome-bin
+_pkgname=flawesome
+pkgver=0.2.3
+pkgrel=1
+epoch=
+pkgdesc="Flawesome is a modern productivity tool that will help you organise your day-today work and thoughts."
+arch=("x86_64")
+url="https://github.com/ashishBharadwaj/flawesome"
+license=('GPL3')
+depends=(
+ 'at-spi2-core'
+ 'gtk3'
+ 'alsa-lib'
+ 'nss'
+ 'libxss'
+)
+optdepends=()
+provides=(xushengfeng)
+conflicts=('flawesome-appimage')
+install=
+source=(
+ "${_pkgname}_${pkgver}_amd64.deb::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb"
+ )
+sha256sums=('1cb04d7b3bb6c57b269c4214b46d7619b6480697b7ac73acd209448711ea4252')
+
+prepare() {
+ bsdtar -xvf data.tar.xz
+ sed 's/Categories=Productivity/Categories=Utility/g' -i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+}
+
+package() {
+ cp --parents -a {opt,usr} "${pkgdir}"
+}