summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCedric Girard2015-11-02 17:08:50 +0100
committerCedric Girard2015-11-02 17:08:50 +0100
commit7ac9d84ecaf2e8e466fc360b6f073fc358ce7086 (patch)
tree4051ccab71ed4efcab684052e394e789cedddbaa /PKGBUILD
parentdd85a39874cd856348a680fa21cd40522a690148 (diff)
downloadaur-7ac9d84ecaf2e8e466fc360b6f073fc358ce7086.tar.gz
build webui files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 642de836ee8c..9c1872f27862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=flexget-git
_pkgname=Flexget
pkgver=1.2.380.r6643.4da9fd2
-pkgrel=1
+pkgrel=2
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more."
@@ -55,6 +55,9 @@ optdepends=('python2-guppy: for memusage plugin' #AUR#
)
makedepends=('python2-paver'
'python2-setuptools'
+ 'npm'
+ 'bower'
+ 'gulp'
)
provides=('flexget')
@@ -82,6 +85,13 @@ prepare() {
python2 ./gen-changelog.py
}
+build() {
+ cd "${_pkgname}"/flexget/ui
+ npm install
+ XDG_CONFIG_HOME="${_srcdir}" bower --config.analytics=false install
+ XDG_CONFIG_HOME="${_srcdir}" gulp
+}
+
package() {
cd "${_pkgname}"