summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2019-02-11 02:57:55 -0500
committerredfish2019-02-11 02:57:55 -0500
commitbefe29669a3d85899b22dce3c15427859772f244 (patch)
tree5a60f5a0f5a02cceb53f3f5dc6060f627cc41d3b /PKGBUILD
parentd076571012762943666b79e8f97fc8f770363fd9 (diff)
downloadaur-befe29669a3d85899b22dce3c15427859772f244.tar.gz
package: cleanup previous build
setuptools doesn't cleanup and files from old build that happen to not be overwritten (because the new version deleted them), remain in the build directory and get included into the package, and cause breakage.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71f5fd8198fe..7a260a252852 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -112,6 +112,9 @@ prepare() {
package() {
cd "${_pkgname}"
+ # Cleanup a previous builds if any, since setuptools doesn't do it
+ rm -rf build
+
# Python setup
python setup.py install --root="${pkgdir}"/ --prefix=/usr --optimize=1 || return 1