summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCedric Girard2017-12-11 17:42:04 +0100
committerCedric Girard2017-12-11 17:42:04 +0100
commitce83af9179f4712f05c193852cc86d71d75564fa (patch)
tree50da9efcbdb7b202d7f2331f636a300123ec0cbc /PKGBUILD
parenta45b6085f7a08c95aceac1ec034a188fb1f8ad8a (diff)
downloadaur-ce83af9179f4712f05c193852cc86d71d75564fa.tar.gz
switch to Python 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD87
1 files changed, 43 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1faa9098e722..0d7c20539388 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=flexget-git
_pkgname=Flexget
-pkgver=2.11.0.r12870.73040fe35
+pkgver=2.11.11.r12945.acccb0c8a
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more."
@@ -14,53 +14,54 @@ arch=('any')
url="http://flexget.com/"
license=('MIT')
-depends=('python2'
+depends=('python'
# documented in requirements.in
- 'python2-feedparser>=5.2.1'
- 'python2-sqlalchemy>=1.0.9'
- 'python2-sqlalchemy<1.999'
- 'python2-yaml'
- 'python2-beautifulsoup4>=4.5'
- 'python2-html5lib>=0.11'
- 'python2-pyrss2gen'
- 'python2-pynzb'
- 'python2-rpyc=3.3.0'
- 'python2-jinja'
- 'python2-requests>=2.16.3'
- 'python2-dateutil>=2.5.3'
- 'python2-jsonschema>=2.0'
- 'python2-path>=8.1.1'
- 'python2-pathlib>=1.0'
- 'python2-guessit<=2.0.4'
- 'python2-rebulk=0.8.2'
- 'python2-apscheduler>=3.2.0'
- 'python2-terminaltables>=3.1.0'
- 'python2-colorclass>=2.2.0'
- 'python2-cherrypy>=3.7.0'
- 'python2-cherrypy<12'
- 'python2-flask>=0.7'
- 'python2-flask-restful>=0.3.3'
- 'python2-flask-restplus=0.10.1'
- 'python2-flask-compress>=1.2.1'
- 'python2-flask-login>=0.4.0'
- 'python2-flask-cors>=2.1.2'
- 'python2-pyparsing>=2.0.3'
- 'python2-zxcvbn'
- 'python2-future>=0.15.2'
+ 'python-feedparser>=5.2.1'
+ 'python-sqlalchemy>=1.0.9'
+ 'python-sqlalchemy<1.999'
+ 'python-yaml'
+ 'python-beautifulsoup4>=4.5'
+ 'python-html5lib>=0.11'
+ 'python-pyrss2gen'
+ 'python-pynzb'
+ 'python-rpyc=3.3.0'
+ 'python-jinja'
+ 'python-requests>=2.16.3'
+ 'python-dateutil>=2.5.3'
+ 'python-jsonschema>=2.0'
+ 'python-path>=8.1.1'
+ 'python-pathlib>=1.0'
+ 'python-guessit<=2.0.4'
+ 'python-rebulk=0.8.2'
+ 'python-apscheduler>=3.2.0'
+ 'python-terminaltables>=3.1.0'
+ 'python-colorclass>=2.2.0'
+ # https://archive.archlinux.org/packages/p/python-cherrypy/python-cherrypy-11.0.0-5-any.pkg.tar.xz
+ 'python-cherrypy>=3.7.0'
+ 'python-cherrypy<12'
+ 'python-flask>=0.7'
+ 'python-flask-restful>=0.3.3'
+ 'python-flask-restplus=0.10.1'
+ 'python-flask-compress>=1.2.1'
+ 'python-flask-login>=0.4.0'
+ 'python-flask-cors>=2.1.2'
+ 'python-pyparsing>=2.0.3'
+ 'python-zxcvbn'
+ 'python-future>=0.15.2'
)
-optdepends=('python2-guppy: for memusage plugin' #AUR#
- 'python2-transmissionrpc: Transmission support' #AUR#
- 'python2-rarfile: decompress plugin' #AUR#
- 'python2-boto3: SNS output plugin' #AUR#
+optdepends=('python-guppy: for memusage plugin' #AUR#
+ 'python-transmissionrpc: Transmission support' #AUR#
+ 'python-rarfile: decompress plugin' #AUR#
+ 'python-boto3: SNS output plugin' #AUR#
)
-makedepends=('python2-paver'
- 'python2-setuptools'
+makedepends=('python-paver'
+ 'python-setuptools'
'yarn'
'bower'
'gulp'
)
-#checkdepends=('python2-vcr')
+#checkdepends=('python-vcr')
provides=('flexget')
conflicts=('flexget')
@@ -82,8 +83,6 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- msg "Patching shebangs to point to python2"
- sed -i 's/\(python\)/\12/' flexget{,/ui}/__init__.py
#pip-compile --output-file requirements.txt requirements.in
#pip-compile give too stricts requirements...
@@ -110,13 +109,13 @@ package() {
cd "${_pkgname}"
# Python setup
- python2 setup.py install --root="${pkgdir}"/ --prefix=/usr --optimize=1 || return 1
+ python setup.py install --root="${pkgdir}"/ --prefix=/usr --optimize=1 || return 1
# License
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
# Make sure the perms allow reading by all
- chmod ugo+r ${pkgdir}/usr/lib/python2.7/site-packages/FlexGet-2.11.*.dev0-py2.7.egg-info/*
+ chmod ugo+r ${pkgdir}/usr/lib/python3.6/site-packages/FlexGet-2.11.*.dev0-py3.6.egg-info/*
# install systemd user unit
install -Dm644 ../flexget.service "${pkgdir}"/usr/lib/systemd/user/flexget.service