summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2019-03-02 11:05:16 -0500
committerredfish2019-03-02 11:05:16 -0500
commitfd592cf5e333f628d2a030145a0a7c55332f20d2 (patch)
treec8e964f212e507edc83dbe4dcfb535be8134625c /PKGBUILD
parentbefe29669a3d85899b22dce3c15427859772f244 (diff)
downloadaur-fd592cf5e333f628d2a030145a0a7c55332f20d2.tar.gz
update to 2.20.7
Also, add the git revision to pkgver as is the convention with VCS packages.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a260a252852..e60a8da99413 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=flexget-git
_pkgname=Flexget
-pkgver=2.18.3
+pkgver=2.20.7.r0.gc7162fdcc
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more."
@@ -75,10 +75,10 @@ sha256sums=('SKIP'
'e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa'
'aceecee5496a34c14c12ed5ad8b97197de32896f358b5aef63a84bf4a419756a')
-#pkgver() {
-# cd Flexget
-# printf "%s.r%s.%s" "$(grep __version__ flexget/_version.py | sed -r "s/.*([0-9].*\.[0-9].*\.[0-9].*)\.dev.*/\1/g")" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-#}
+pkgver() {
+ cd "${_pkgname}"
+ git describe --tags --long | sed 's/^v//' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
cd "${_pkgname}"