summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2017-03-20 13:26:34 -0400
committerGuillaume Horel2017-03-20 13:26:34 -0400
commitc1406e013d8cc4968a346533b11faadbd82d4fe7 (patch)
tree688acb49b5c450b97aa9e371a3e5fd42918d3914 /PKGBUILD
parentd362d5d7986a7162db3bd60c9236b517438894f7 (diff)
downloadaur-c1406e013d8cc4968a346533b11faadbd82d4fe7.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a908eb607a4..b798f4214347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('i686' 'x86_64')
url="http://flexisip.org"
license=('AGPL3')
groups=()
-depends=('belle-sip' 'boost-libs' 'hiredis' 'mediastreamer' 'protobuf' 'sofia-sip-bc' 'unixodbc' 'xsd' 'soci')
+depends=('belle-sip' 'boost-libs' 'hiredis' 'mediastreamer' 'protobuf' 'sofia-sip-bc>=1.13.12' 'unixodbc' 'xsd' 'soci')
makedepends=()
optdepends=()
provides=()
@@ -17,12 +17,14 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/BelleDonneCommunications/$pkgname/archive/$pkgver.tar.gz")
+source=("git+https://github.com/BelleDonneCommunications/$pkgname.git#commit=cf47b79bd656"
+ "flexisip.service")
noextract=()
-md5sums=('aa42bc3fee319e731947c2e00dff4eb3')
+sha256sums=('SKIP'
+ '2a96c6604c62ea6b70f0bd6e96c6910afef6e17ac8d44ce0a50cce60279946be')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
./autogen.sh
./configure --prefix=/usr \
@@ -42,7 +44,8 @@ build() {
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
make DESTDIR="$pkgdir/" install
+ install -Dm0644 "$srcdir/flexisip.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
}