summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Muscariello2021-03-11 20:51:30 +0100
committerFabian Muscariello2021-03-11 20:51:30 +0100
commit326f296f9043f48a82b4af0329ad41063300647d (patch)
treea954f13dcaa859128e6e9f7aed0c689918d7d670 /PKGBUILD
parent269d65bcc225203e50cb4000c2d0d230a190b884 (diff)
downloadaur-326f296f9043f48a82b4af0329ad41063300647d.tar.gz
Install flexo_purge_cache
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ef3657de071..94f33de1dec3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: nroi <nroi@mailbox.org>
pkgname=flexo-git
pkgrel=1
-pkgver=1.0.6.r4.g95d4407
+pkgver=1.1.0.r1.g4a47024
pkgdesc="A central pacman cache"
# TODO we haven't tested yet if this package can be built on ARM architectures.
arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -9,7 +9,7 @@ url='https://github.com/nroi/flexo'
license=('MIT')
provides=("flexo")
makedepends=('cargo' 'git')
-depends=('curl')
+depends=('curl' 'pacman-contrib')
backup=('etc/flexo/flexo.toml')
install="${pkgname%-git}.install"
source=('git+https://github.com/nroi/flexo.git'
@@ -41,4 +41,5 @@ package() {
install -Dm644 "${srcdir}/sysuser.conf" "${pkgdir}/usr/lib/sysusers.d/flexo.conf"
install -Dm644 "${pkgname%-git}/${pkgname%-git}/conf/flexo.toml" "$pkgdir/etc/flexo/flexo.toml"
install -Dm755 "${pkgname%-git}/${pkgname%-git}/target/release/flexo" "$pkgdir/usr/bin/flexo"
+ install -Dm755 "${pkgname%-git}/flexo_purge_cache" "$pkgdir/usr/bin/flexo_purge_cache"
}