summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMicah Elliott2017-02-20 11:47:33 -0800
committerMicah Elliott2017-02-20 11:47:33 -0800
commit431b23f3f6f9d1aa45a6286e89425e1e24d9eeb2 (patch)
tree0c5701dbddba4f62353c95f06517c3bd4b995f6d /PKGBUILD
parent325aa7b2ee962a23c776d1a0e13e8897fa77734c (diff)
downloadaur-431b23f3f6f9d1aa45a6286e89425e1e24d9eeb2.tar.gz
new release using new aur git process
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 38 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e2473b806df..cc6094f3451d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,56 @@
-# Author: Micah Elliott <mde@MicahElliott.com>
-# package guidelines: https://wiki.archlinux.org/index.php/VCS_package_guidelines
-
-pkgname=flickpapr
-_pkgname=flickpapr
-pkgver=r23.83f6ae9
+# Maintainer: Micah Elliott <mde at micahelliott dot com>
+pkgname=flickpapr-git
+# pkgver=r24.86adcc7
+pkgver=r27.0a1e152
pkgrel=1
pkgdesc='randomly choose an “interesting” flickr photo for desktop wallpaper'
arch=('any')
url='https://github.com/MicahElliott/flickpapr'
-license=('WTFPL')
+license=('GPL')
+groups=()
depends=('zsh' 'ruby' 'ruby-nokogiri' 'libnotify' 'feh' 'imagemagick' 'daemonize' 'dunst')
-provides=($_pkgname=$pkgver)
makedepends=('git')
-source=('git://github.com/MicahElliott/flickpapr.git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/MicahElliott/flickpapr.git')
+noextract=()
md5sums=('SKIP')
pkgver() {
- cd $_pkgname
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/${pkgname%-git}"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ : cd "$srcdir/${pkgname%-git}"
+}
+
+build() {
+ : cd "$srcdir/${pkgname%-git}"
+}
+
+check() {
+ : cd "$srcdir/${pkgname%-git}"
}
package() {
- cd $_pkgname
+ cd "$srcdir/${pkgname%-git}"
install -Dm755 bin/flickpapr $pkgdir/usr/bin/flickpapr
install -Dm755 bin/flickloop $pkgdir/usr/bin/flickloop
install -Dm755 bin/flickd $pkgdir/usr/bin/flickd
install -Dm755 share/flickpapr/flickr-icon-64.png $pkgdir/usr/share/flickpapr/flickr-icon-64.png
install -d -Dm755 $pkgdir/usr/share/flickpapr/
- install -Dm755 share/flickpapr/flickr-icon-bw-64.png $pkgdir/usr/share/flickpapr/flickr-icon-bw-64.png
+ install -Dm755 share/flickpapr/flickr-icon-bw-64.png $pkgdir/usr/share/flickpapr/flickr-icon-bw-64.png
}
-
-# vim:set ts=2 sw=2 et: