summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2017-10-16 11:27:01 -0400
committerSolomon Choina2017-10-16 11:27:01 -0400
commitf2a921373e6c77826b168a9172eb0e0eb43e08e0 (patch)
treebe29ef817979daafecfe498c9974b3b7f92d19c4 /PKGBUILD
parent3331c88f540578f82d7c04bfbeedf228635a810c (diff)
downloadaur-flite-fpic.tar.gz
update pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d1afa2e1527..89ca00e1d504 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgname=flite-fpic
_pkgname=flite
-pkgver=1.4
-pkgrel=10
+pkgver=2.0.0
+_pkgver=2.0
+pkgrel=1
pkgdesc="A lighweight version of festival speech synthesis compiled with -fPIC"
arch=('i686' 'x86_64')
url="http://www.speech.cs.cmu.edu/flite/"
@@ -12,14 +13,28 @@ depends=('glibc' 'alsa-lib')
provides=('flite' 'flite-fpic')
replaces=('flite')
options=('!makeflags')
-source=(http://www.festvox.org/flite/packed/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}-release.tar.bz2
+source=(http://www.festvox.org/flite/packed/${_pkgname}-${_pkgver}/${_pkgname}-${pkgver}-release.tar.bz2
+ https://launchpad.net/ubuntu/+archive/primary/+files/${_pkgname}_${pkgver}-release-4.debian.tar.xz
${pkgname}.patch)
-md5sums=('b7c3523b3bbc6f29ce61e6650cd9a428'
- 'd818853cb4e416b76457ed63df7fde9c')
+sha256sums=('678c3860fd539402b5d1699b921239072af6acb4e72dc4720494112807cae411'
+ 'b4f4656f9bf397bb86d78721d87259629e53f3c0dd0fec10dd08b7750d0ffc3e'
+ 'adae4cba9c0af88ee1570bb3800ab8b826b9f6c60640ffce92b41871d54763e2')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}-release"
- patch -p1 -i ../${pkgname}.patch
+
+ patches=(CVE-2014-0027_unsafe_temporary_file.patch
+ exactly.patch
+ flite.texi.patch
+ no_rpath.patch
+ shlib_deps.patch
+ texi2html_to_texi2any_migration.patch
+ )
+ patch -Np1 -i ../${pkgname}.patch
+ for patch in "${patches[@]}"; do
+ patch -Np1 -i ../debian/patches/${patch}
+ done
+
}
build() {
@@ -28,7 +43,7 @@ build() {
#we want the 16k, not 8k voice
sed -i 's/cmu_us_kal/cmu_us_kal16/' config/config
-
+
#no parallel builds
export MAKEFLAGS="-j1"
make -j1