summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomZ2020-05-26 23:59:18 +0200
committerTomZ2020-05-26 23:59:18 +0200
commitd3fb10f24453e5cb5f281f11d0361d7b8798c1ac (patch)
tree3012f92322fc50ded8629acc51633f9ec17d581d /PKGBUILD
parent2237e4a79d4de255d14a9a23a4b3237bc3805d89 (diff)
downloadaur-d3fb10f24453e5cb5f281f11d0361d7b8798c1ac.tar.gz
Introduce 'flowee-libs' dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb661ec229dc..35d8064b9fe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ license=('GPL3')
depends=('boost-libs' 'libevent' 'openssl')
makedepends=('boost' 'cmake' 'pkgconf')
optdepends=('miniupnpc')
-provides=('flowee-hub')
+provides=('flowee-hub' 'flowee-libs')
backup=("etc/flowee/flowee.conf")
install=flowee.install
source=("https://gitlab.com/FloweeTheHub/thehub/-/archive/$pkgver/thehub-$pkgver.tar.gz"
@@ -29,7 +29,7 @@ build() {
(cd thehub-$pkgver && patch -p1 -i ../testing_patch.diff)
mkdir -p build
cd build
- cmake -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub-$pkgver
+ cmake -Denable_gui=false -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub-$pkgver
make
}