summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomZ2020-03-24 20:28:31 +0100
committerTomZ2020-03-24 20:28:31 +0100
commite09a053be34753b46aef8f5bed466b33a56c5472 (patch)
treec2bf9e21e039b7db39a14303be163dbf6d538029 /PKGBUILD
parentf731a76fc72d8ed219846cfd3885db30316297ba (diff)
downloadaur-e09a053be34753b46aef8f5bed466b33a56c5472.tar.gz
new version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 579109914acd..2cc317aedd13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tom Zander
pkgname=flowee
-pkgver=2019.10.1
+pkgver=2020.02.1
pkgrel=1
pkgdesc="Flowee Bitcoin products"
arch=('x86_64')
@@ -12,12 +12,12 @@ makedepends=('boost' 'cmake' 'autoconf' 'automake' 'pkgconf')
provides=('flowee-hub')
backup=("etc/flowee/flowee.conf")
install=flowee.install
-source=("git+https://gitlab.com/FloweeTheHub/thehub.git#branch=2019.10"
+source=("https://gitlab.com/FloweeTheHub/thehub/-/archive/2020.02.1/thehub-$pkgver.tar.gz"
"flowee.logrotate"
"flowee.conf"
"logs.conf")
-sha256sums=('SKIP'
+sha256sums=("7038635181f490babd723d33864e8a07287b8569bdefe9db4130703599beae36"
"aff02b3312c88113fe7316152c15f1545233dc8c2062ee8c36d2dbcad4a9f5bf"
"bc14acf0d1b4064553756a1e81c0b943e842296f2a2af6442e480b846392e6bc"
"784a4cdc77d1767299ab10119288c21b478b205d560ae86bc9782b04ae2f82fc")
@@ -25,7 +25,7 @@ sha256sums=('SKIP'
build() {
mkdir -p build
cd build
- cmake -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub
+ cmake -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub-$pkgver
make -j1 univalue leveldb
make
}
@@ -44,7 +44,7 @@ package() {
mv etc/flowee/flowee.conf etc/flowee/flowee-example.conf
install -Dm 664 "$srcdir/flowee.conf" -t "$pkgdir/etc/flowee"
install -Dm 664 "$srcdir/logs.conf" -t "$pkgdir/etc/flowee"
- install -Dm 644 "$srcdir/thehub/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$srcdir/thehub/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 664 "$srcdir/thehub/support/indexer.conf" -t "$pkgdir/etc/flowee"
+ install -Dm 644 "$srcdir/thehub-$pkgver/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "$srcdir/thehub-$pkgver/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 664 "$srcdir/thehub-$pkgver/support/indexer.conf" -t "$pkgdir/etc/flowee"
}