summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorD3SOX2021-04-06 08:44:17 +0200
committerD3SOX2021-04-06 08:44:17 +0200
commit2acf82156c7dcc3202ec542495804f2c702e52a0 (patch)
tree4e07cd549457d3bad6bab127b9c645d9cf983f1b /PKGBUILD
parent84954cce1dfb5c1e3ad86a3f991bb6f923962bb2 (diff)
downloadaur-2acf82156c7dcc3202ec542495804f2c702e52a0.tar.gz
add /usr/bin symlink
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4406230f8bf..d6481be733dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=fluent-reader
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
_pkgname="${pkgname}-${pkgver}"
pkgdesc='Modern desktop RSS reader built with Electron, React, and Fluent UI'
arch=('any')
@@ -27,6 +27,10 @@ package() {
install -d "$pkgdir/opt/"
cp -dr --no-preserve=ownership "bin/linux/x64/linux-unpacked" "$pkgdir/opt/$pkgname"
+ # install binary symlink
+ install -d "${pkgdir}/usr/bin/"
+ ln -sf /opt/soundux/soundux "${pkgdir}/usr/bin/soundux"
+
install -Dm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
install -Dm644 "build/icons/512x512.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"