summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThe one with the braid2024-05-24 15:47:20 +0200
committerThe one with the braid2024-05-24 15:47:20 +0200
commit55939e88ae0fcd40f5ccb62e258e82ed3edbddd5 (patch)
treeb500a9d057c97b1afdf712c3259638ad247093f8 /PKGBUILD
parentf274caad0e17fa2551c8e37812b4a9d209cd891b (diff)
downloadaur-55939e88ae0fcd40f5ccb62e258e82ed3edbddd5.tar.gz
fix: empty CMakeCache in prepare
Signed-off-by: The one with the braid <info@braid.business>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0aaf2dd3c0a3..5725c3bede16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=fluffychat
_name=${pkgname}
_appid=chat.fluffy.fluffychat
pkgver=1.20.0
-pkgrel=6
+pkgrel=7
pkgdesc="Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized."
# Flutter officially supports amd64 and AArch64
arch=('x86_64' 'aarch64')
@@ -58,6 +58,11 @@ prepare() {
# enter the source directory
cd "${srcdir}/${_name}-${pkgver}"
+ # ensure a clean CMakeCache
+ if [ -f "build/linux/${_dartarch}/release/CMakeCache.txt" ]; then
+ rm "build/linux/${_dartarch}/release/CMakeCache.txt"
+ fi
+
# download dart dependencies without lockfile update or retry with
flutter pub get --enforce-lockfile || flutter pub get
}