summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThe one with the braid2024-04-04 21:25:37 +0200
committerThe one with the braid2024-04-04 21:25:37 +0200
commit559400790a7085e37e900d8bd5fffb70c25acaa6 (patch)
treeb1f3b7c11d319932205116f3a9714f153dc8c8e6 /PKGBUILD
parent0292fc627d30c97ae818c0e588dec566c8485382 (diff)
downloadaur-559400790a7085e37e900d8bd5fffb70c25acaa6.tar.gz
fix: add SQLCipher patch
Signed-off-by: The one with the braid <info@braid.business>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 680c1721c490..cd8c32e442f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=fluffychat
pkgver=1.19.0
-pkgrel=3
+pkgrel=4
pkgdesc="Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized."
arch=('x86_64' 'aarch64')
url="https://fluffychat.im/"
@@ -19,6 +19,8 @@ depends=(
'libolm'
# flutter_file_picker - see https://github.com/miguelpruivo/flutter_file_picker/blob/master/lib/src/linux/file_picker_linux.dart#L115
'zenity'
+ # sqlite encryption
+ 'openssl'
)
makedepends=(
'flutter-tool'
@@ -26,8 +28,12 @@ makedepends=(
)
provides=("$pkgname")
conflicts=("$pkgname")
-source=("fluffychat-v${pkgver}.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f')
+source=(
+ "fluffychat-v${pkgver}.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v${pkgver}.tar.gz"
+ "system-sqlcipher.patch"
+)
+sha256sums=('0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f'
+ 'b5b2beb552414e692c4cf6def9d74e8327a968dc15747cc0fb794f226e6633e7')
prepare() {
# overriding CMake flags for aarch64 in order to ensure build
@@ -42,11 +48,12 @@ prepare() {
cd ${pkgname}-$pkgver
flutter pub get
+ patch --follow-symlinks -p1 -i "${srcdir}/system-sqlcipher.patch" -d .
}
build() {
cd ${pkgname}-$pkgver
- flutter build linux --release --verbose
+ flutter build linux --no-pub --release --verbose
}
package() {