summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRuben De Smet2018-12-12 15:56:15 +0100
committerRuben De Smet2018-12-12 15:56:15 +0100
commit758f6eeec9f19c3b22faca0037739acc62ba2081 (patch)
treeecd5afc25c773b7f58267575687e7ff662f30c5d /PKGBUILD
downloadaur-758f6eeec9f19c3b22faca0037739acc62ba2081.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96cb4d9d5a05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+_pkgname=fluidkeys
+pkgname=$_pkgname-git
+pkgver=release.r87.g63f3e8e
+pkgrel=1
+pkgdesc='Fluidkeys helps teams protect themselves with strong encryption.'
+arch=('any')
+url="https://www.fluidkeys.com"
+license=('AGPL3')
+makedepends=('go-pie' 'rsync')
+provides=("fluidkeys=$pkgver")
+source=("git+https://github.com/fluidkeys/fluidkeys.git")
+sha256sums=('SKIP')
+
+_gopath="gopath/src/github.com/fluidkeys/fluidkeys"
+
+pkgver() {
+ cd $_pkgname
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ mkdir -p "$srcdir/gopath/src/github.com/fluidkeys"
+ ln -rTsf $_pkgname "$srcdir/$_gopath"
+ export GOPATH="$srcdir/gopath"
+ cd $srcdir/$_gopath
+ dep ensure
+}
+
+build() {
+ cd "$srcdir/$_gopath"
+ export GOPATH="$srcdir/gopath"
+ make
+}
+
+package() {
+ cd $srcdir/$_gopath
+ export GOPATH="$srcdir/gopath"
+
+ make install PREFIX="$pkgdir/usr"
+}