summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGimmeapill2022-01-12 22:17:29 +0100
committerGimmeapill2022-01-12 22:17:29 +0100
commit3a0af5fbb3080eca0fe60fe839e19cf31d44a557 (patch)
tree240277b941c652d92c2cbffa0e7d6d465e6236ce /PKGBUILD
parent0607c5f681fea95398c567fc347d811021bf7a18 (diff)
downloadaur-3a0af5fbb3080eca0fe60fe839e19cf31d44a557.tar.gz
use https to fetch the source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6680a2c40bb8..91aa4f8e3adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gimmeapill <gimmeapill at gmail dot com>
pkgname=fluidplug-git
-pkgver=r36.889b256
+pkgver=r37.8457f10
pkgrel=1
pkgdesc="SoundFonts as LV2 plugins via FluidSynth"
arch=('i686' 'x86_64')
@@ -9,10 +9,10 @@ url="https://github.com/falkTX/FluidPlug"
license=('CCPL')
groups=('lv2-plugins')
depends=('fluidsynth')
-makedepends=('git' 'wget' 'lv2' 'p7zip')
+makedepends=('git' 'wget' 'lv2' 'p7zip' 'fluidsynth')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git://github.com/falkTX/FluidPlug.git")
+source=("${pkgname%-*}::git+https://github.com/falkTX/FluidPlug.git")
sha256sums=('SKIP')
pkgver() {
@@ -20,6 +20,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${pkgname%-*}"
+ make DESTDIR=$pkgdir download
+}
+
build() {
cd "${srcdir}/${pkgname%-*}"
make DESTDIR=$pkgdir