summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThe one with the braid2024-03-27 08:47:17 +0100
committerThe one with the braid2024-03-27 08:47:17 +0100
commit4e9e05bb176edfd1cdb193d1c362a1a52fa32314 (patch)
tree5ada5b3e4eba27c57243af2e633e0c7ba63219a9 /PKGBUILD
parentb47014f6f3c09e6c44b30d607cf249f32a1e568c (diff)
downloadaur-4e9e05bb176edfd1cdb193d1c362a1a52fa32314.tar.gz
fix: provide metapackage flutter-full to provide the group
Signed-off-by: The one with the braid <info@braid.business>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d29074daedf..aa19cf543d8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -104,10 +104,9 @@ build() {
find "$PUB_CACHE" -name '*.aot' -delete
}
-_package-full() {
+_package() {
pkgdesc="${_pkgdesc} - full installation of development tool and runtime"
depends=("${pkgbase}-devel=${pkgver}" "${pkgbase}-target-linux=${pkgver}" "${pkgbase}-target-android=${pkgver}" "${pkgbase}-target-web=${pkgver}" "${pkgbase}-intellij-patch"=${pkgver})
- provides=("${_group}")
}
_package-common() {
@@ -267,7 +266,7 @@ _package-intellij-patch() {
ln -sf "${DART_ROOT:-"/opt/dart-sdk"}" "${pkgdir}/usr/lib/${_group}/bin/cache/dart-sdk"
}
-pkgname=("${_group}-full" "${_group}-common" "${_group}-gradle" "${_group}-tool" "${_group}-devel" "${_group}-target-linux" "${_group}-target-android" "${_group}-target-web" "${_group}-intellij-patch")
+pkgname=("${_group}" "${_group}-common" "${_group}-gradle" "${_group}-tool" "${_group}-devel" "${_group}-target-linux" "${_group}-target-android" "${_group}-target-web" "${_group}-intellij-patch")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {