summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWithTheBraid2022-06-28 08:41:01 +0200
committerWithTheBraid2022-06-28 08:41:01 +0200
commit530505f15feb21daf2a30effe3f5d1dedf76fd44 (patch)
tree225932c2659b400a53704963b761d0acf88bee60 /PKGBUILD
parentab74cfdd9d5e7f68ccf754d09c09990aff1072d7 (diff)
downloadaur-530505f15feb21daf2a30effe3f5d1dedf76fd44.tar.gz
fix: missing write-permission on hash files
- make particular cache files read-write for end-users Signed-off-by: WithTheBraid <the-one@with-the-braid.cf>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d75792eaf34..2e8e5f230cd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,6 +37,7 @@ package() {
"${pkgdir}/opt/${pkgname}/bin/flutter" precache
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod a+rx {} +
find "${pkgdir}/opt/${pkgname}" -type f -exec chmod a+r {} +
- chmod a+rw "${pkgdir}/opt/${pkgname}/version"
+ # those files *must* be read-write for end-users
+ chmod a+rw "${pkgdir}/opt/${pkgname}/version" "${pkgdir}/opt/${pkgname}/bin/cache/lockfile" "${pkgdir}/opt/${pkgname}/bin/cache/usbmuxd.stamp" "${pkgdir}/opt/${pkgname}/bin/cache/libmobiledevice.stamp"
ln -s "/opt/${pkgname}/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}