summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWithTheBraid2022-06-16 13:33:34 +0200
committerWithTheBraid2022-06-16 13:36:26 +0200
commitbfccc1a3c13b047d5b1ef14f260c79e8697c84a7 (patch)
tree455d76bbbfb74acb2f9483e280289110178ed8bc /PKGBUILD
parentb9d12ed6fc4cf48bfe4c681e12aa09eb6e7f81c3 (diff)
downloadaur-bfccc1a3c13b047d5b1ef14f260c79e8697c84a7.tar.gz
feat: include Dart SDK cache into package
Fixes: #23 Signed-off-by: WithTheBraid <the-one@with-the-braid.cf>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 565fac34a6a6..92b2f30af86d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="A new mobile app SDK to help developers and designers build modern mobi
arch=("x86_64")
url="https://${pkgname}.dev"
license=("custom" "BSD" "CCPL")
-depends=("git" "glu" "java-environment" "libglvnd" "unzip")
+depends=("git" "glu" "java-environment" "libglvnd" "unzip" "curl")
optdepends=("android-sdk" "android-studio" "intellij-idea-community-edition" "intellij-idea-ultimate-edition" "ninja" "perl" "python")
makedepends=("python")
backup=("opt/${pkgname}/packages/${pkgname}_test/pubspec.yaml" "opt/${pkgname}/packages/${pkgname}/pubspec.yaml")
@@ -33,6 +33,8 @@ package() {
install -dm755 "${pkgdir}/opt/${pkgname}"
install -dm755 "${pkgdir}/usr/bin"
cp -ra "${srcdir}/${pkgname}" "${pkgdir}/opt/"
+ ${pkgdir}/opt/${pkgname}/bin/internal/update_dart_sdk.sh
+ ${pkgdir}/opt/${pkgname}/bin/flutter precache
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod a+rx {} +
find "${pkgdir}/opt/${pkgname}" -type f -exec chmod a+r {} +
chmod a+rw "${pkgdir}/opt/${pkgname}/version"