summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThe one with the braid2024-03-25 12:10:33 +0100
committerThe one with the braid2024-03-25 12:10:33 +0100
commitc4389a06a84f184ede25141a951e47c894991e56 (patch)
treeb95ce728bea0593b80d297e623bb4bdffa9ac52b /PKGBUILD
parent654a7f3fd0f58ce131abb3ae16ce61f21ad17d23 (diff)
downloadaur-c4389a06a84f184ede25141a951e47c894991e56.tar.gz
fix: configure Gradle cache and build dir
Signed-off-by: The one with the braid <info@braid.business>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a222b4997019..31a28f4be0bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _flutterarch=$(uname -m | sed s/aarch64/arm64/ | sed s/x86_64/x64/)
# this host is blocked in China, according to Flutter docs, the FLUTTER_STORAGE_BASE_URL environment variable
# should be used to provide an alternative mirror
_storagebase="${FLUTTER_STORAGE_BASE_URL:-"https://storage.googleapis.com"}"
-pkgrel=3
+pkgrel=4
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64" "aarch64")
url="https://${pkgname}.dev"
@@ -114,10 +114,12 @@ source=(
# engine/linux-$ARCH
"font-subset.zip::${_storagebase}/flutter_infra_release/flutter/${_enginever}/linux-${_flutterarch}/font-subset.zip"
+ "system-dart.patch"
+ "gradle-user-home.patch"
+
# thanks to lauren n. liberda from Alpine for the awesome patchset used here !
"${pkgname}.sh"
"version.patch"
- "system-dart.patch"
"no-lock.patch"
"no-runtime-download.patch"
"doctor.patch"
@@ -186,9 +188,10 @@ sha256sums=('089f924c72f28d25851382d70db83df83c64746713f6a8ca08879a1530adb8ca'
'70edb9c63fe08d77cb2a9b59f9d4d1ec16e28a49737e8dd0cdbf5ccefcc562bb'
'6f5d86f207c78cb64744889c34ed3ac45e403ea035d512674e5b348cb0d6355a'
'05778e62c2da50d8280dc55589225871bf90bb2d543b48d2f1d6acd73460d573'
+ '8d2422220b5cdcbe7757cefa576045c92c4b013708a0a88c8d378484e1adb24e'
+ 'de0d3567d83bd756841b19ccf879efc02749d8a45cf18d94cd71ec1d366c9024'
'54db9347ac6467b806fff70f62b2709276a0ca4d82468ae8357d5520db0ad04a'
'688a7d6a3c220cf09f7e48af46f1ef1b01d251679962c825eded0b3fa4fc2ab1'
- '8d2422220b5cdcbe7757cefa576045c92c4b013708a0a88c8d378484e1adb24e'
'544d08716332a9f9358b21010d468b84a9edff0da7bbb1baf0cf4d6322821ea5'
'a5f19e68e9e4790d017dc4988e715f51c44548df5615aae6106d1a0c84fe49f1'
'04531ee1732c18c933b5b28f5da88ed183d5aa3698b1d1e912c000928b93ec91'
@@ -196,8 +199,9 @@ sha256sums=('089f924c72f28d25851382d70db83df83c64746713f6a8ca08879a1530adb8ca'
prepare() {
mv "${srcdir}/${pkgname}-${pkgver/.hotfix/+hotfix}" "${srcdir}/${pkgname}"
- patch -p1 -i "${srcdir}/version.patch" -d "${srcdir}/${pkgname}"
patch -p1 -i "${srcdir}/system-dart.patch" -d "${srcdir}/${pkgname}"
+ patch -p1 -i "${srcdir}/gradle-user-home.patch" -d "${srcdir}/${pkgname}"
+ patch -p1 -i "${srcdir}/version.patch" -d "${srcdir}/${pkgname}"
patch -p1 -i "${srcdir}/no-lock.patch" -d "${srcdir}/${pkgname}"
patch -p1 -i "${srcdir}/no-runtime-download.patch" -d "${srcdir}/${pkgname}"
patch -p1 -i "${srcdir}/doctor.patch" -d "${srcdir}/${pkgname}"
@@ -276,7 +280,6 @@ EOF
unzip -o -q "${srcdir}/gtk-profile-${_flutterarch}.zip" -d engine/linux-${_flutterarch}-profile
unzip -o -q "${srcdir}/gtk-release-${_flutterarch}.zip" -d engine/linux-${_flutterarch}-release
unzip -o -q "${srcdir}/font-subset.zip" -d engine/linux-${_flutterarch}
-
}
build() {
@@ -299,10 +302,4 @@ package() {
install -dm755 "${pkgdir}/usr/bin"
cp -ra "${srcdir}/${pkgname}" "${pkgdir}/usr/lib"
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/flutter"
-
- # didn't find a workaround other than keeping that one still user writable
- install -dm777 "${pkgdir}/usr/lib/${pkgname}/packages/flutter_tools/gradle/.gradle"
- install -dm777 "${pkgdir}/usr/lib/${pkgname}/packages/flutter_tools/gradle/build"
- touch "${pkgdir}/usr/lib/${pkgname}/packages/flutter_tools/gradle/.gradle/.keep"
- touch "${pkgdir}/usr/lib/${pkgname}/packages/flutter_tools/gradle/build/.keep"
}