summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWithTheBraid2023-06-21 14:40:51 +0200
committerWithTheBraid2023-06-21 14:40:51 +0200
commitd09e8ddddb58259064fd81fde06d5a3af1cbad23 (patch)
treec3e64079064c2058eb1aa5522f9be4bb09c19e95 /PKGBUILD
parent7c96b27873f0516db0f7feec84178fc94746bcf3 (diff)
downloadaur-d09e8ddddb58259064fd81fde06d5a3af1cbad23.tar.gz
fix: missing file permissions
Signed-off-by: WithTheBraid <the-one@with-the-braid.cf>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 914f165de405..159210db30a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,8 +44,9 @@ package() {
# those files *must* be read-write for end-users; not my fault *grumble*
chmod a+rw "${pkgdir}/opt/${pkgname}" "${pkgdir}/opt/${pkgname}/.pub-preload-cache"
- chmod -R a+rw "${pkgdir}/opt/${pkgname}/version" "${pkgdir}/opt/${pkgname}/bin/cache" "${pkgdir}/opt/${pkgname}/.git"
- find "${pkgdir}/opt/${pkgname}" -name "pubspec.lock" -exec chmod a+r+ {} +
+ chmod -R a+rw "${pkgdir}/opt/${pkgname}/version" "${pkgdir}/opt/${pkgname}/bin/cache" "${pkgdir}/opt/${pkgname}/.git"
+ find "${pkgdir}/opt/${pkgname}" -name "pubspec.lock" -exec chmod a+rw {} +
+ find "${pkgdir}/opt/${pkgname}" -name "package_config.json" -exec chmod a+rw {} +
# fix git ref migrations
mv "${pkgdir}/opt/${pkgname}/.git" "${pkgdir}/opt/${pkgname}/.git-refs"