summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrealgagu2018-12-03 18:36:43 -0500
committerfrealgagu2018-12-03 18:36:43 -0500
commit2c84aa79873c4eb5e9e4237e588a1be8c8d92254 (patch)
treefec2609ac56c967efb12aae4a83cfd8ff3ba52dc /PKGBUILD
parenteb5c4ab2c7e132e50040e8ce61e20d9f26897e29 (diff)
downloadaur-2c84aa79873c4eb5e9e4237e588a1be8c8d92254.tar.gz
Upgrading to version 0.11.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfeb569b1006..6d28be7a82a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=flutter-dev
-pkgver=0.11.12
+pkgver=0.11.13
pkgrel=1
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64")
@@ -27,7 +27,7 @@ install="${pkgname%-dev}.install"
source=("${pkgname%-dev}-${pkgver}.tar.xz::https://storage.googleapis.com/flutter_infra/releases/dev/linux/${pkgname%-dev}_linux_v${pkgver}-dev.tar.xz"
"${pkgname%-dev}.sh"
"${pkgname%-dev}.csh")
-sha256sums=("77cd27683cecbc09dfa4c34c0f14b84afdcd14f98a79463137b3177d8fcb621d"
+sha256sums=("a1ec730b4922a8b9d11858f45099dfdc106ecb7c3502911e1ee49594af9e7be5"
"1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a"
"7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f")
@@ -40,9 +40,11 @@ package() {
install -Dm644 "${srcdir}/${pkgname%-dev}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm755 "${srcdir}/${pkgname%-dev}.sh" "${pkgdir}/etc/profile.d/${pkgname%-dev}.sh"
install -Dm755 "${srcdir}/${pkgname%-dev}.csh" "${pkgdir}/etc/profile.d/${pkgname%-dev}.csh"
- install -d "${pkgdir}/opt/${pkgname%-dev}/"
+ install -dm755 "${pkgdir}/opt/${pkgname%-dev}"
+ install -dm755 "${pkgdir}/usr/bin"
cp -ra "${srcdir}/${pkgname%-dev}" "${pkgdir}/opt/"
find "${pkgdir}/opt/${pkgname%-dev}" -type d -exec chmod a+rx {} +
find "${pkgdir}/opt/${pkgname%-dev}" -type f -exec chmod a+r {} +
chmod a+rw "${pkgdir}/opt/${pkgname%-dev}/bin/cache/lockfile" "${pkgdir}/opt/${pkgname%-dev}/version"
+ ln -rTsf "/opt/${pkgname%-dev}/bin/${pkgname%-dev}" "${pkgdir}/usr/bin/${pkgname%-dev}"
}