summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrealgagu2020-05-17 17:42:31 -0500
committerfrealgagu2020-05-17 17:42:31 -0500
commit154450aeb74287dde5cb93b1bd254286fda1d4d1 (patch)
treea912c09cd7b6638ae292fc756b72cd21c63a0952 /PKGBUILD
parentc76ec5a62663e310ac1b603a94245c54ab0771ef (diff)
downloadaur-154450aeb74287dde5cb93b1bd254286fda1d4d1.tar.gz
Deleting cache files.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9a4c4549358..1dcfeeedc29d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=flutter-git
-pkgver=1.4.19.r2.27b058a414
+pkgver=1.19.0.1.0.pre.r83.8abf0a6d8c
pkgrel=1
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64")
@@ -52,6 +52,7 @@ build() {
}
package() {
+ rm -rf "${srcdir}/${pkgname%-git}/bin/cache" "${srcdir}/${pkgname%-git}/.pub-cache"
install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm755 "${srcdir}/${pkgname%-git}.sh" "${pkgdir}/etc/profile.d/${pkgname%-git}.sh"
install -Dm755 "${srcdir}/${pkgname%-git}.csh" "${pkgdir}/etc/profile.d/${pkgname%-git}.csh"
@@ -60,6 +61,6 @@ package() {
cp -ra "${srcdir}/${pkgname%-git}" "${pkgdir}/opt/"
find "${pkgdir}/opt/${pkgname%-git}" -type d -exec chmod a+rx {} +
find "${pkgdir}/opt/${pkgname%-git}" -type f -exec chmod a+r {} +
- chmod a+rw "${pkgdir}/opt/${pkgname%-git}/bin/cache/lockfile" "${pkgdir}/opt/${pkgname%-git}/version"
+ chmod a+rw "${pkgdir}/opt/${pkgname%-git}/version"
ln -s "/opt/${pkgname%-git}/bin/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
}