summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:28:17 -0600
committerBrian Bidulock2015-06-10 05:28:17 -0600
commit285cbea4c7d3e49f779e25eabe9c13ec9934914c (patch)
treedc03e7ba745d848a4db9b190e79efb9b25b383af /PKGBUILD
downloadaur-285cbea4c7d3e49f779e25eabe9c13ec9934914c.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e52b83c82d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Devin Cofer <ranguvar@archlinux.us>
+# Contributor: CainĂ£ Costa <sryche@archlinux-br.org>
+# Contributor: Patrick Bartels <p4ddy.b@gmail.com>
+
+pkgname=fluxbox-git
+pkgdesc="Lightweight stacking WM with tabbing, dockapps, etc."
+pkgver=1.3.7.16.g69d1333
+pkgrel=2
+arch=(i686 x86_64)
+url=http://www.fluxbox.org/
+license=(MIT)
+depends=(fribidi imlib2 libxft libxinerama libxpm libxrandr)
+makedepends=(git)
+optdepends=('xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities')
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+options=(!libtool)
+source=($pkgname::git://git.fluxbox.org/${pkgname%-*}.git
+ $pkgname.desktop)
+md5sums=('SKIP'
+ 'c3cf99bfa58862724e0061e3881679aa')
+
+pkgver() {
+ cd $pkgname/
+ git describe --tags --long | sed 's|Release-||;s|[_-]|.|g'
+}
+
+build() {
+ cd $pkgname/
+ autoreconf -fi
+ ./configure --prefix=/usr --enable-xft --enable-xinerama --enable-imlib2 --enable-nls
+ make
+}
+
+package() {
+ cd $pkgname/
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/xsessions/${pkgname%-*}.desktop
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}