summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlain Kalker2016-04-03 21:35:26 +0200
committerAlain Kalker2016-04-03 21:36:27 +0200
commitcc05b577da36417f35dd2b3b397fdb4ae9c5eb49 (patch)
treec54e26b028a5e53c94f885c808e4abf9ca93a3eb /PKGBUILD
parent4d5b737e09da451b8e8a1b4bed2c90fcd492d1e7 (diff)
downloadaur-cc05b577da36417f35dd2b3b397fdb4ae9c5eb49.tar.gz
Add desktop file and icon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac7d53b943c6..a470c6dbb119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=fluxus
pkgname=${_pkgname}-git
pkgver=v0.17rc5.r224.gd06cb52
-pkgrel=1
+pkgrel=2
pkgdesc="A 3D game engine for livecoding worlds into existence"
arch=('i686' 'x86_64')
url="http://www.pawfal.org/fluxus/"
@@ -36,6 +36,12 @@ package() {
cd "$srcdir/$_pkgname"
scons DESTDIR="$pkgdir/" Prefix=/usr RacketPrefix=/usr install
+
+ # Install icon and desktop file
+ install -d "$pkgdir"/usr/share/pixmaps
+ install -m 644 modules/material/textures/fluxus-icon.png "$pkgdir"/usr/share/pixmaps
+ install -d "$pkgdir"/usr/share/applications
+ install -m 644 debian/fluxus.desktop "$pkgdir"/usr/share/applications
}
# vim:set ts=2 sw=2 et: