summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commita13cc357d76cdf70dd2072e28d0606e148c02422 (patch)
tree71c0555fe360e33fc73a8d562778576dda54d462 /PKGBUILD
downloadaur-a13cc357d76cdf70dd2072e28d0606e148c02422.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..225f704fc61c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Mantainer: 3ED <krzysztof1987 at gmail>
+
+pkgname=flv2x264
+pkgver=0.2.a1
+pkgrel=1
+pkgdesc="flv to avi converter"
+arch=('any')
+license=('GPL2')
+depends=('ffmpeg' 'bash')
+optdepends=('libx264: h264 support'
+ 'libtheora: ogg/theora support'
+ 'libvpx: vp8 support'
+ 'faac: aac support'
+ 'libvorbis: ogg/vorbis support'
+ 'lame: mp3 support')
+url="https://github.com/3ed/flv2x264"
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/3ed/flv2x264/archive/v${pkgver}.tar.gz)
+sha256sums=('14f7e252d6c0234f7d508d3bbb21a43e99fdb60c1294ee2203c1ab1bea6f71d0')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -dm755 "$pkgdir/usr/bin"
+ install -m0755 bin/flv2x264 "$pkgdir/usr/bin/flv2x264"
+}