summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-02-16 18:29:05 -0800
committerxiota2023-02-16 19:03:38 -0800
commit70708df615f18a05d466d6a32ede2184b204e856 (patch)
treec6602b4ef02f4dfbd552bd91b3bf12aa23109802 /PKGBUILD
parent536af148b22b340dce2fa8c53f076b79858eab08 (diff)
downloadaur-70708df615f18a05d466d6a32ede2184b204e856.tar.gz
flycast 2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 35 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 077cba5fa488..eb753c52dd6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,36 @@
_pkgname=flycast
pkgname="$_pkgname"
-pkgver=2.0
+pkgver=2.1
+_tag="V$pkgver"
pkgrel=1
pkgdesc='A multi-platform Sega Dreamcast, Naomi and Atomiswave emulator'
arch=('x86_64' 'i686')
url="https://github.com/flyinghead/flycast"
license=('GPL2')
-depends=('libgl' 'libzip' 'zlib' 'alsa-lib')
-makedepends=('git' 'cmake' 'python' 'systemd')
+depends=(
+ 'alsa-lib'
+ 'hicolor-icon-theme'
+ 'libgl'
+ 'libzip'
+)
+makedepends=(
+ 'cmake'
+ 'git'
+ 'python'
+ 'systemd'
+)
provides=("$_pkgname" reicast)
conflicts=("$_pkgname")
source=(
- "$_pkgname"::"git+$url.git#tag=v$pkgver"
+ "$_pkgname"::"git+$url.git#tag=$_tag"
"SDL"::"git+https://github.com/libsdl-org/SDL"
+ "Vulkan-Headers"::"git+https://github.com/KhronosGroup/Vulkan-Headers"
+ "VulkanMemoryAllocator"::"git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator"
+ "breakpad"::"git+https://github.com/flyinghead/mingw-breakpad"
+ "glslang"::"git+https://github.com/KhronosGroup/glslang"
"libchdr"::"git+https://github.com/rtissera/libchdr"
"luabridge"::"git+https://github.com/vinniefalco/LuaBridge"
- "breakpad"::"git+https://github.com/flyinghead/mingw-breakpad"
+ "oboe"::"git+https://github.com/google/oboe"
)
md5sums=(
'SKIP'
@@ -23,13 +38,26 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
prepare() {
cd "$srcdir/$_pkgname"
- # git submodule update --init --recursive
- for submodule in core/deps/{SDL,libchdr,luabridge,breakpad}; do
+ _submodules=(
+ 'core/deps/SDL'
+ 'core/deps/Vulkan-Headers'
+ 'core/deps/VulkanMemoryAllocator'
+ 'core/deps/breakpad'
+ 'core/deps/glslang'
+ 'core/deps/libchdr'
+ 'core/deps/luabridge'
+ 'core/deps/oboe'
+ )
+ for submodule in ${_submodules[@]} ; do
git submodule init ${submodule}
git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
git -c protocol.file.allow=always submodule update ${submodule}