summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Oteiza2015-06-08 22:55:27 -0400
committerMark Oteiza2015-06-08 22:55:27 -0400
commit04115683a91c83311fd35acf84357f5b2e16230e (patch)
treef87b9315200b52d8da759c723d7710cc4fb193a9 /PKGBUILD
downloadaur-04115683a91c83311fd35acf84357f5b2e16230e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68958757532b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: holos
+
+pkgname=flycheck
+pkgver=0.23
+pkgrel=1
+pkgdesc='Modern on-the-fly syntax checking extension for GNU Emacs'
+arch=('any')
+url="http://flycheck.readthedocs.org/"
+license=('GPL')
+# groups=('emacs-plugins')
+depends=('emacs' 'emacs-dash')
+makedepends=('emacs' 'texinfo')
+install=flycheck.install
+source=("https://github.com/flycheck/flycheck/archive/$pkgver.tar.gz")
+sha256sums=('edda4967780f3566842c87b7a5d7f2630be593b9029a7909e5c02f68c82ee9e3')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ emacs --batch -f batch-byte-compile flycheck.el
+ makeinfo --force --no-split -o doc/flycheck.info doc/flycheck.texi
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -d "$pkgdir/usr/share/emacs/site-lisp/flycheck"
+ install -Dm644 flycheck.{el,elc} "$pkgdir/usr/share/emacs/site-lisp/flycheck"
+ install -Dm644 doc/flycheck.info "$pkgdir/usr/share/info/flycheck.info"
+}