summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlan Bunbury2019-11-17 10:43:42 +0000
committerAlan Bunbury2019-11-17 10:43:42 +0000
commit1f7fc0cf26a549de55d38a960d09ca65bff11601 (patch)
treef0ba9f62373bbeb1bb24bb86e1e7e33e2886de8d /PKGBUILD
downloadaur-1f7fc0cf26a549de55d38a960d09ca65bff11601.tar.gz
first commit of package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2f5a2881bda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alan Bunbury
+pkgname=flying-robots
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A three-dimensional clone of the classic BSD Robots game."
+arch=('any')
+url="https://github.com/bunburya/FlyingRobots"
+license=('MIT')
+depends=('python')
+optdepends=('tk: For tkinter-based UI')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("http://bunburya.eu/apps/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+md5sums=('ce38284174e6cf15c0ca710c15bce486')
+
+# vim:set ts=2 sw=2 et: