summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2019-01-07 12:31:35 +0200
committerAdrian Perez de Castro2019-01-07 12:31:35 +0200
commitd86475c6618f3f71960bda69dacbf8f1ae9b913d (patch)
tree944882e0a42cd7a2d26baceb526663ab56d2f23a /PKGBUILD
parenta30053c5d0983b4559341005b0b2e4d6715dd9a7 (diff)
downloadaur-d86475c6618f3f71960bda69dacbf8f1ae9b913d.tar.gz
Use compiler/linker flags set in makepkg.conf
This ensures that the binaries are built with RELRO and optimizations chosen by the user in their makepkg.conf configuration file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5951d6deb024..82d1c5e02f98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Adrián Pérez de Castro <adrian@perezdecastro.org>
-pkgname='fmsx'
pkgdesc='Portable MSX/MSX2/MSX2+ emulator'
-pkgver='5.4'
-pkgrel='1'
+pkgname=fmsx
+pkgver=5.4
+pkgrel=2
_dlname="fMSX${pkgver//./}"
url='http://fms.komkon.org/fMSX'
license=('custom')
@@ -50,8 +50,8 @@ prepare () {
build () {
cd "${srcdir}"
cat > config.mk <<-EOF
- CFLAGS += $(pkg-config libpulse-simple --cflags)
- LIBS += $(pkg-config libpulse-simple --libs)
+ CFLAGS += ${CFLAGS} $(pkg-config libpulse-simple --cflags)
+ LIBS += ${LDFLAGS} $(pkg-config libpulse-simple --libs)
EOF
make -C fMSX/Unix
}