summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornight07212024-03-10 12:12:08 +0000
committernight07212024-03-10 12:12:08 +0000
commit2af8337ead231a985782a69a3b335e536c3868e5 (patch)
tree154d22960b0c789d7ae3aa02cdc56f10e0634279 /PKGBUILD
downloadaur-2af8337ead231a985782a69a3b335e536c3868e5.tar.gz
Adding PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bdad7681580
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Night Kaly <night@night0721.xyz>
+pkgname=fnf
+pkgver=0.1
+pkgrel=1
+pkgdesc="A simple fuzzy finder for the terminal"
+arch=('x86_64')
+url="https://github.com/leo-arch/fnf"
+license=('MIT')
+optdepends=('clifm: to use with clifm')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/leo-arch/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('878eae406a5fdc9e8b88d28c264f772da258ddad8378c50b8e08cbc9ce0df07a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="/usr" install
+}