summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciek Borzecki2020-05-29 16:01:27 +0200
committerMaciek Borzecki2020-05-29 16:01:27 +0200
commit46aca39e3ee908238cd0366fb8a1e83ae32c0560 (patch)
tree6a153d431d8cfb85a0f1b42502a920f48e30686d /PKGBUILD
downloadaur-46aca39e3ee908238cd0366fb8a1e83ae32c0560.tar.gz
Initial upload: fnotifystat 0.02.05-1
Initial packaging of fnotifystat. Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..356fbc2929a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Maciek Borzecki <maciek.borzecki@gmail.com>
+pkgname=fnotifystat
+pkgver=0.02.05
+pkgrel=1
+pkgdesc="file activity monitoring tool"
+arch=('x86_64')
+url="https://kernel.ubuntu.com/~cking/fnotifystat/"
+license=('GPL2')
+depends=()
+optdepends=('bash-completion: bash completion support')
+source=("https://kernel.ubuntu.com/~cking/tarballs/fnotifystat/$pkgname-$pkgver.tar.gz")
+sha256sums=('293e12ffb7890bc8af8dce498b3742062be5b085c0a926aa3949ea300eee17ad')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ for name in "${source[@]}"; do
+ if [[ "${name%.patch}" == "$name" ]]; then
+ # not a patch
+ continue
+ fi
+ msg2 "applying $name"
+ patch -p1 -i "$srcdir/$name"
+ done
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ # sbin is a symlink to bin, so we need to adjust the path
+ mv "$pkgdir/usr/sbin" "$pkgdir/usr/bin"
+}