summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-02-18 22:21:38 -0600
committerLuis Martinez2021-02-18 22:21:38 -0600
commit17e97904bb0f805d14a20da88a36fcd0f63ebfb4 (patch)
treed8def4f39392d8e30c89ba41e087b86bcf9f0a0a /PKGBUILD
downloadaur-17e97904bb0f805d14a20da88a36fcd0f63ebfb4.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb4b16ec81d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: lmartinez-mirror
+pkgname=fnott
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Keyboard driven and lightweight Wayland notification daemon"
+arch=('x86_64')
+url="https://codeberg.org/dnkl/fnott"
+license=('MIT')
+depends=('dbus' 'fontconfig' 'freetype2' 'pixman' 'libpng' 'wayland' 'wlroots' 'fcft')
+makedepends=('git' 'meson' 'ninja' 'scdoc' 'wayland-protocols' 'tllist>=1.0.1')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('5f8c3ba29af792875b0ac2e585cfebd453c92be064711b9d82a5cf6249fccda2cdeacc2a96b0b8b4a485590f10255d3e257339d85c99cccc3158ebc516959f22')
+
+build() {
+ cd "$pkgname"
+ meson --prefix=/usr --buildtype=release build
+ ninja -C build
+}
+
+package() {
+ cd "$pkgname"
+ DESTDIR="$pkgdir/" ninja -C build install
+}