summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMahmoud Nagy2017-06-02 04:16:04 +0200
committerMahmoud Nagy2017-06-02 04:16:04 +0200
commit00b0232213ac9c11d989400d86c7d99260dc931c (patch)
treeda047876f7132033453dc1e4bc00611b177d7052 /PKGBUILD
parent4bd2bb0b2aca2a3e25c429cab77e5925510c21a5 (diff)
downloadaur-00b0232213ac9c11d989400d86c7d99260dc931c.tar.gz
changed to libappindicator and icons fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9d754d63a28..bc3027534f86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: nagyation <mnagy1312@gmail.com>
pkgname=focus-git
_newpkgname=Focus
-pkgver=r42.7626df4
+pkgver=r52.c5e651b
pkgrel=1
-pkgdesc="A desktop notification based app that keeps you focused"
+pkgdesc="A desktop notification based app that keeps you focused by notifying you of what you should be doing"
arch=(x86_64)
url="https://github.com/nagyation/Focus"
license=('GPL')
-depends=('gtk2' 'libnotify')
+depends=('gtk2' 'libnotify' 'libappindicator-gtk3' 'gtk-update-icon-cache')
makedepends=('git')
source=("git+https://github.com/nagyation/Focus.git")
md5sums=('SKIP')
@@ -26,5 +26,6 @@ package() {
cd "$_newpkgname"
install -D -m644 "License.txt" "${pkgdir}/usr/share/licenses/${_newpkgname}/LICENSE"
install -D -m755 "focus" "${pkgdir}/usr/bin/focus"
- install -D -m755 "resources/focus_icon.png" "${pkgdir}/usr/share/focus/focus_icon.png"
+ install -D -m755 "icons/focus-icon.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/focus-icon.svg"
+ gtk-update-icon-cache -f -t /usr/share/icons/hicolor
}