summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-08-17 09:47:13 -0600
committerMark Wagie2021-08-17 09:47:13 -0600
commit760b45f88a59ee5f873dfbe4c437ea519b7779c0 (patch)
treee6880618a43c4a720d65fec4e5811349bef7c318 /PKGBUILD
parent3cb097f44cf83c0b097923ab2fea38d7cb3efcaf (diff)
downloadaur-760b45f88a59ee5f873dfbe4c437ea519b7779c0.tar.gz
PKGBUILD adjustments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 862bad1cd6ab..6be028eb0645 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,28 +9,22 @@ url="https://github.com/costales/folder-color"
license=('GPL3')
depends=('folder-color-common' 'nautilus' 'python-nautilus')
makedepends=('git' 'python-distutils-extra')
-conflicts=("$pkgname-bzr" "$pkgname-git")
_commit=e76d1d92e2d1418fa1dcd3f418a8919a2842140d
source=("git+https://github.com/costales/folder-color.git#commit=$_commit")
sha256sums=('SKIP')
-pkgver() {
- cd "$srcdir/$_pkgname"
- printf "%s" "$(head -n 1 debian/changelog | cut -d'(' -f 2 | cut -d')' -f 1 | sed 's/-/./')"
-}
-
prepare() {
- cd "$srcdir/$_pkgname/install_scripts"
- ./nautilus.sh
+ cd "$srcdir/$_pkgname/install_scripts"
+ ./nautilus.sh
}
build() {
- cd "$srcdir/$_pkgname"
- python setup.py build
+ cd "$srcdir/$_pkgname"
+ python setup.py build
}
package() {
- cd "$srcdir/$_pkgname"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$srcdir/$_pkgname"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}