summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2018-11-04 20:06:54 -0500
committerTed Alff2018-11-04 20:06:54 -0500
commit9afa83573a62fabf1ac5d419c990e4186b2eb4a8 (patch)
tree52702ceb9e3ec02ceeb17f4cc5b5bd8d3309e5d6 /PKGBUILD
parent3e8d043f16aeafd79b0913bc299b34cb6d966f6a (diff)
downloadaur-9afa83573a62fabf1ac5d419c990e4186b2eb4a8.tar.gz
Python 3 port for nemo-python 4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b28053ff1563..a6cd8c366de3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=folder-color-switcher
-pkgver=1.2.3
+pkgver=1.2.3+3+3320effe
pkgrel=1
pkgdesc="Folder color switcher for Nemo and Caja"
arch=('any')
url="https://github.com/linuxmint/folder-color-switcher"
license=('GPL')
-optdepends=('nemo-python: Nemo extension'
+optdepends=('nemo-python>=3.9.0: Nemo extension'
'python2-caja: Caja extension')
-options=('!libtool' '!emptydirs')
-
-source=("${pkgname}-${pkgver}.tar.gz::http://packages.linuxmint.com/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver}.tar.gz")
-sha256sums=('8b882aad2af32ccc3725ca4dfffed6bfe49551bac9a14abff1428ab77a142beb')
+makedepends=('git')
+#source=("${pkgname}-${pkgver}.tar.gz::http://packages.linuxmint.com/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver}.tar.gz"
+# 'python3.patch')
+_commit='3320effe5cb713af82bd0d0e34ab75e067925cff'
+source=("${pkgname}"::git+https://github.com/linuxmint/folder-color-switcher#commit=${_commit})
+sha256sums=('SKIP')
build() {
- cd ${srcdir}/${pkgname}
+ cd "${srcdir}/${pkgname}"
make
}
package() {
- cd ${srcdir}/${pkgname}
+ cd "${srcdir}/${pkgname}"
cp -r usr "${pkgdir}"
}