summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSchwonder Reismus2019-07-14 21:20:06 +0300
committerSchwonder Reismus2019-07-14 21:20:06 +0300
commit05902d12a9faf3e97281b6f3b0f1b2bc77f87a79 (patch)
tree1d42e6daedc3c7ad76c2be77f0399f5d9123a61c /PKGBUILD
parent83aa6293bceeb1d2546f3abf8668acd7605f4d24 (diff)
downloadaur-05902d12a9faf3e97281b6f3b0f1b2bc77f87a79.tar.gz
Bump version to 1.5.0; testing auto-update from Github
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f45aeecedb2..6880a963476b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: schw0reismus <schw0reismus@protonmail.com>
pkgname=foliate
-pkgver=1.4.0
-pkgrel=2
+pkgver=1.5.0
+pkgrel=1
pkgdesc="A simple and modern GTK eBook reader"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://johnfactotum.github.io/foliate/"
@@ -11,19 +11,29 @@ depends=('gjs>=1.52.0' 'webkit2gtk')
makedepends=('meson>=0.40' 'ninja' 'gettext')
optdepends=('hyphen: Auto-hyphenation support'
'hyphen-en: Hyphenation rules for English; you may choose package for your language'
- 'dictd: Offline dictionary support')
-source=(https://github.com/johnfactotum/${pkgname}/archive/${pkgver}.tar.gz)
+ 'dictd: Offline dictionary support'
+ 'festival: Text-to-speech support; also voice package needed'
+ 'espeak-hg: Text-to-speech support; also voice package needed')
+#source=(https://github.com/johnfactotum/${pkgname}/archive/${pkgver}.tar.gz)
+source=($pkgname::git+https://github.com/johnfactotum/$pkgname.git)
provides=("$pkgname")
conflicts=("$pkgname-git")
-sha256sums=('481d051299dcc26918f453e635730313ad00fac33cc8d61594e4289fff1159fd')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
+ git checkout -b $pkgver
+ git pull origin $pkgver
meson build --prefix=/usr
ninja -C build
}
package(){
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
DESTDIR="$pkgdir" ninja -C build install
}