summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSchwonder Reismus2019-07-14 21:25:30 +0300
committerSchwonder Reismus2019-07-14 21:25:30 +0300
commit357002d770e835a2269bfeb5b163b3fa31ea5586 (patch)
tree7f90413a2b3d0c8e12e2812187049d528f6b1189 /PKGBUILD
parent05902d12a9faf3e97281b6f3b0f1b2bc77f87a79 (diff)
downloadaur-357002d770e835a2269bfeb5b163b3fa31ea5586.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6880a963476b..134209b2f4bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,17 +16,17 @@ optdepends=('hyphen: Auto-hyphenation support'
'espeak-hg: Text-to-speech support; also voice package needed')
#source=(https://github.com/johnfactotum/${pkgname}/archive/${pkgver}.tar.gz)
source=($pkgname::git+https://github.com/johnfactotum/$pkgname.git)
-provides=("$pkgname")
-conflicts=("$pkgname-git")
+provides=($pkgname)
+conflicts=($pkgname-git)
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd $srcdir/$pkgname
git describe --tags
}
build() {
- cd "$srcdir/$pkgname"
+ cd $srcdir/$pkgname
git checkout -b $pkgver
git pull origin $pkgver
meson build --prefix=/usr
@@ -34,6 +34,6 @@ build() {
}
package(){
- cd "$srcdir/$pkgname"
- DESTDIR="$pkgdir" ninja -C build install
+ cd $srcdir/$pkgname
+ DESTDIR=$pkgdir ninja -C build install
}